Splash screen not appearing and variable names

You have trouble using InstallForge? Then this is the right place for you.
Post Reply
astropiper
Posts: 3
Joined: Mon Jul 06, 2020 3:26 am

Hello,

I'm using InstallForge 1.4.2, and using Windows 10. Thank you for sharing this great tool.

I selected "Show Splash Screen Dialog", and even after trying either png and bmp file,
the installer doesn't show anything nor it installs software defined in Setup/Files.
However, if I use the same script and uncheck "Show Splash Screen Dialog",
the installer created works correctly.

Would you guide me why this is not working?

On the other hand, I'd like to use the "Website URL" variable to create a shortcut on
Windows' Start Menu. Is there a list of variables created within IF that we can reference
to in different screens, much like <AppName>, or <InstallPath>, etc.

Thank you very much!

Mart
Kurasiu
Posts: 1
Joined: Fri Aug 14, 2020 11:23 pm

I want to bump this topic, as the splash screen doesn't work for me either, and I'd really need to use one. Currently the compiled installer doesn't do anything when I build it with a splash screen, it only works when that option is ticked off.
User avatar
Soner
Posts: 127
Joined: Mon Sep 15, 2014 12:36 pm

Hello,

we can confirm that there is an issue with the splash screen feature. Will be fixed in the next version.

Concerning the variables: https://installforge.net/support/docs/u ... constants/
astropiper
Posts: 3
Joined: Mon Jul 06, 2020 3:26 am

Thank you Soner,

I appreciate the response. It's been a busy couple of months and I'm glad this will be addressed on the next build.

M
Post Reply